Как сравнить две строки в Excel

Как сравнить две строки в Excel

При применении табличного процессора Microsoft Office Excel, помимо задач сопоставления числовых значений, частенько бывает нужно сравнить и текстовые («строковые») данные ячеек таблицы. Это дозволено сделать, воспользовавшись встроенными в Excel функциями сопоставления, если итог операции нужно получить и виде цифрового либо логичного значения. А дозволено применять опции условного форматирования, если итогом должно быть визуальное выделение совпадающих (либо несовпадающих) ячеек таблицы.

Инструкция

1. Воспользуйтесь встроенной функцией сопоставления ячеек СЧЁТЕСЛИ, если нужно сравнить текстовые значения в ячейках колонки таблицы с примером текста и пересчитать все совпадающие значения. Начните с заполнения колонки текстовыми значениями, а после этого в иной колонке щелкните ячейку, в которой хотите видеть итог подсчета, и введите соответствующую формулу. Скажем, если проверяемые значения находятся в колонке A, а итог нужно разместить в первую ячейку колонки C, то ее содержимое должно быть таким:=СЧЁТЕСЛИ($A:$A;”Виноград”)Тут «Виноград» – строковое значение, с которым сравниваются значения всех ячеек колонки A. Дозволено не указывать его в формуле, а разместить в отдельную ячейку (скажем – в B1) и вставить в формулу соответствующую ссылку:=СЧЁТЕСЛИ($A:$A;B1)

2. Используйте опции условного форматирования, если нужно визуально выделить в таблице итог сопоставления строковых переменных. Скажем, если нужно выделить в колонке A ячейки, текст в которых совпадает с примером в ячейке B1, то начните с выделения этой колонки – щелкните ее заголовок. После этого щелкните кнопку «Условное форматирование» в группе команд «Жанры» закладки «Основная» меню Excel. Перейдите в раздел «Правила выделения ячеек» и выберите строку «Равно». В открывшемся окошке укажите ячейку-пример (щелкните клетку B1) и выберите в выпадающем списке вариант оформления совпадающих строк. После этого нажмите кнопку «OK».

3. Используйте комбинацию встроенных функций ЕСЛИ и СЦЕПИТЬ при необходимости сравнить с примером не одну текстовую ячейку, а несколько. Функция СЦЕПИТЬ соединяет указанные ей значения в одну строковую переменную. Скажем, команда СЦЕПИТЬ(A1;” и “;B1) к строке из ячейки A1 добавит текст « и », а позже него разместит строку из ячейки B1. Сконструированную таким методом строку после этого дозволено сравнить с примером с поддержкой функции ЕСЛИ. Когда сопоставлять нужно не одну строку комфортнее дать собственное имя ячейке-примеру. Для этого щелкните ее и слева от строки формул взамен обозначения ячейки (скажем, C1) наберите ее новое имя (скажем, «пример»). После этого кликните ту ячейку, в которой должен быть итог сопоставления, и введите формулу:ЕСЛИ(СЦЕПИТЬ(A1;” и “;B1)=пример;1;0)Тут единица – это значение, которое будет содержать ячейка с формулой, если сопоставление даст позитивный итог, а нуль – для негативного итога. Размножить эту формулу на все строки таблицы, которые необходимо сравнить с примером дюже примитивно – наведите курсор на правый нижний угол ячейки и, когда курсор изменится (станет черным крестиком), нажмите левую кнопку мыши и растяните эту ячейку вниз до последней сопоставляемой строки .

Понравилась статья? Поделиться с друзьями:
Добавить комментарий